import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^-]*-){2}\\s*\\K[^/]+";
final String string = "a - bc/def_g - A/mn/us/ww\n"
+ "opq - rs/ts_uf - BC/wx/yza\n"
+ "Abc - so/dhie7u - XYZ/En/xy/jkq - QWNE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}