using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[-+.\w]+\b@(?:(?!\.gov)\S)+(?!\S)";
string input = @"abc123@abc.c # 'o' is in 'gov' so it ends the returned string there
456@email.edu
governmentemail@governmentaddress. #'.gov' omitted
test@test.gov
test.test@test.org.gov.test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}