const regex = new RegExp('[-+.\\w]+\\b@(?:(?!\\.gov)\\S)+(?!\\S)', 'gm')
const str = `abc123@abc.c # 'o' is in 'gov' so it ends the returned string there
456@email.edu
governmentemail@governmentaddress. #'.gov' omitted
test@test.gov
test.test@test.org.gov.test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}