import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".car\\s{0,5}\\(([^]]+)\\)";
final String string = "Only one car(52;model-14557) had a good engine(workable condition), others engine were damaged beyond repair\n\n"
+ "Other car(21, model-155) looked in good condition but car ( 36, model-8878) looked to be in terrible condition.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}