re = /.car\s{0,5}\(([^]]+)\)/
str = 'Only one car(52;model-14557) had a good engine(workable condition), others engine were damaged beyond repair
Other car(21, model-155) looked in good condition but car ( 36, model-8878) looked to be in terrible condition.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end