// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".car\s{0,5}\(([^]]+)\)").unwrap();
let string = "Only one car(52;model-14557) had a good engine(workable condition), others engine were damaged beyond repair
Other car(21, model-155) looked in good condition but car ( 36, model-8878) looked to be in terrible condition.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}