import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w*)?,(.*)?,\\s?(\\d+)?,(\\w+)?";
final String string = "Jhon,12\" Main Third ,2012,GR\n\n"
+ "Lew,\"291\" Line (12,596,3)\",2012,GR\n\n"
+ ",All, 1992,FR";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}