$re = '/(?:[^,]*,\s*){3}(?<test>[^,]+)\s+,/';
$str = '12/11/2018 , abc , def , ced test123 , xyz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);