const regex = /(?m)^\b.*(^(?!SERIAL|TT).+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^\\b.*(^(?!SERIAL|TT).+)', 'g')
const str = `CONT NEG TESTS - ALL PINS
SERIAL NUMBER: 15 MODULE: 0 Mon Jan 1 03:41:42 2007
TT STMT PIN MEAS VALUE FORCING LESS THAN GREATER THAN
---- ---- --- --------------- --------------- ---------- ------------`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}