re = /(?m)^\b.*(^(?!SERIAL|TT).+)/
str = 'CONT NEG TESTS - ALL PINS
SERIAL NUMBER: 15 MODULE: 0 Mon Jan 1 03:41:42 2007
TT STMT PIN MEAS VALUE FORCING LESS THAN GREATER THAN
---- ---- --- --------------- --------------- ---------- ------------'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end