import Foundation
let pattern = #"^(?P<JUNK>.*?)(?!\(.\))(\(.*\))?\sname\:(?P<name>\d+)\.$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ID pqr () name:123.
ID pqr (a) () name:123.
ID pqr (a) (b) () name:123.
ID pqr (a) (b) () name:123.
ID pqr (a) (b) (XX) name:123.
ID pqr (a) (b) (X) name:123.
ID pqr (aa) (b) (X) name:123.
ID pqr (a) (bb) (X) name:123.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)