$re = '~^browse/(coffee|goodies)/([A-Za-z0-9\%\+\-]+)/([0-9]+)/?~m';
$str = 'browse/goodies/Books+%26+DVDs/3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);