$re = '/(.*)(?:,[^,]*){2}$/m';
$str = 'suite 1, street 1, zip city, country';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);