using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^T|\G(?!^)).*?\Ke";
string substitution = @"3";
string input = @"The quick brown fox jumps over the lazy dog.
She opened the door.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}