use strict;
my $str = 'The quick brown fox jumps over the lazy dog.
She opened the door.';
my $regex = qr/(?:^T|\G(?!^)).*?\Ke/mp;
my $subst = '3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";