import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(.+-front))(.*?)-(glass|glass-.*?lcd|lcd)-.*?(replacement|repair)(.*?)";
final String string = "iphone-repair/iphone-4s-repair/iphone-4s-lcd-repair\n"
+ "iphone-repair/iphone-4s-repair/iphone-4s-glass-repair\n"
+ "iphone-repair/iphone-4s-repair/iphone-4s-glass-amp-lcd-replacement\n"
+ "iphone-repair/iphone-4s-repair/iphone-4s-front-glass-amp-lcd-amp-back-glass-replacement";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}