package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(mp|tm|de)\b`)
var str = `samplemp okay de hellotm
blatm theHK end`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}