$re = '/@when\(((?:[^()]*(?:(\((?:[^()]+|(?2))*+\)))?)*+)\)/m';
$str = '@when(\'foo\')
@when(function(\'foo\'))
@when(function([\'foo\' => \'bar\']))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);