re = /([^\s=]+) *= *\S/m
str = 'Is this true car=truck
Is this true car.myCar=truck'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end