# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\(\d\)[^(]+"
test_str = "(4) The Governor-General may arrange\\n with the Chief Minister of the Australian Capital Territory for the variation or revocation of an \\n\\narrangement in force under subsection (3). \\nNorthern Territory \\n (5) The Governor-General may make arrangements with the \\nAdministrator of the Northern \\nTerritory with respect to the "
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.