$re = '/(<[^>]*\sstyle=)"([^"]+)"([^>]*>)/m';
$str = 'Améliorer <span style="color:black;">mon authentification</span>
';
$subst = "\1\\\"\2\\\"\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;