import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\bprostat)(?=\\w{0,3}\\b))";
final String string = "/*ITALIAN*/\n"
+ "Neoformazione del palato duro in paziente affetto da ca della prostata.\n"
+ "Frustoli agoboptici di parenchima prostatico. \n"
+ "Il complesso dei reperti orienta in prima ipotesi per localizzazione di carcinoma di origine prostatica.\n"
+ "Agobiopsie prostatiche multiple\n"
+ "Ipertrofia prostatica.\n\n"
+ "/*ENGLISH*/\n"
+ "New formation of the hard palate in a patient affected by prostate cancer.\n"
+ "Fragments showing hypertrophic prostate parenchyma.\n"
+ "The combination of findings suggests a preliminary diagnosis of prostate-origin carcinoma.\n"
+ "Multiple prostatic core biopsies.\n"
+ "Prostatic hypertrophy.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}