using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"--(?<myfield>[^-\n]+)--";
string input = @"10.231.247.162--WTLDNDAA001--Can't ping DSLAM
10.44.69.250--TCSUAZMS--VisibilityOnly--Can't ping DSLAM
10.44.69.250--TCSUAZMS--Can't ping DSLAM--VisibilityOnly
172.31.247.148--CLSPCO32H01.2--Can't ping DSLAM
172.31.166.155--RSBGORBU--Can't ping DSLAM ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}