$re = '/--(?<myfield>[^-\n]+)--/m';
$str = '10.231.247.162--WTLDNDAA001--Can\'t ping DSLAM
10.44.69.250--TCSUAZMS--VisibilityOnly--Can\'t ping DSLAM
10.44.69.250--TCSUAZMS--Can\'t ping DSLAM--VisibilityOnly
172.31.247.148--CLSPCO32H01.2--Can\'t ping DSLAM
172.31.166.155--RSBGORBU--Can\'t ping DSLAM ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);