import re
regex = re.compile(r"\d+(?:\.\d+)?p?x?", flags=re.MULTILINE)
test_str = "2pxy...12py...12px...12ppx...12...12ypx"
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)