re = /^(?:\"([^\"]*)\")|(?:\'([^\']*)\')$/m
str = '"ajdojsd \'adas\'"
\'adaodpkosad" "\'
\'hello\' '
subst = '$1peter file$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result