package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{2}).(\d{2}).(\d{2})`)
var str = `23.03.15
21.12.24
`
var substitution = "20$1-$2-$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}