const regex = /^(\d{2}).(\d{2}).(\d{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{2}).(\\d{2}).(\\d{2})', 'gm')
const str = `23.03.15
21.12.24
`;
const subst = `20$1-$2-$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);