use strict;
my $str = '23.03.15
21.12.24
';
my $regex = qr/^(\d{2}).(\d{2}).(\d{2})/mp;
my $subst = '20$1-$2-$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";