import Foundation
let pattern = #"^(\d{2}).(\d{2}).(\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
23.03.15
21.12.24
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"20$1-$2-$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)