// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{2}(0[1-9]|1[012])(0[1-9]|[12][0-9]|3[01])\d{6}$").unwrap();
let string = "190131958103
201331958103
190100958103
190132958103
190031958103
441201485383
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}