$re = '/^(?!000|666|9\d\d)\d{3}-(?!00)\d\d-(?!0000)\d\d\d\d$/m';
$str = '888888888
123456789
888-88-8888
123-45-6789
111-22-3333
333-33-3333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);