#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Diagnostic-Code[\s\S]*?[\r\n]{2}"
Local $sString = "..." & @CRLF & _
"Status: 5.0.0" & @CRLF & _
"Diagnostic-Code: X-Postfix; skalio.com" & @CRLF & _
"*this*" & @CRLF & _
"*should*" & @CRLF & _
"*be included too*" & @CRLF & _
"" & @CRLF & _
"--EA7634814EFB9.1516804532/mail.example.com" & @CRLF & _
"Content-Description: Undelivered Message" & @CRLF & _
"..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")