import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((([1-9][0-9]{0,2})(,\\d{3})*(\\.\\d+)?)|(([1-9][0-9]*)(\\.\\d+)?))$";
final String string = "0,999,999,999,999,999.0\n"
+ "10,999,999,999,999,9899.9\n"
+ "99,999\n"
+ "9.99\n"
+ "09,999\n"
+ "0999998\n"
+ "09999\n"
+ "9.9\n"
+ "999,99\n"
+ "9,999\n"
+ "999.0\n"
+ "abc123\n"
+ "66666666666666666666.098\n"
+ "888888888\n"
+ "0.999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}