const regex = /^(\d{9})([0-2]{1})([0-0]{1})([0-3]{1})([0-9]{8})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{9})([0-2]{1})([0-0]{1})([0-3]{1})([0-9]{8})$', '')
const str = `00099326620118160014`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}