$re = '/([1][0]\d{2})/m';
$str = '1000
1001
1002
1003
1004
1099
1210';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);