#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\w*|\(.*\))(\(class=(\".*\")\))"
Local $sString = "+image(class="sumup-illustration, vector" src="/sumup-x-debitoor-guide/final_illustration_sumup_en.svg" alt="Meet a better way to stay on top of your SumUp payments") " & @CRLF & _
"+image(class="classTest1, classTest2, classTest3, classTest4") " & @CRLF & _
"+grid__item("md-4", "md-vertical-4x-gutter", "xs-first", "md-last")(class="accent, button, link") " & @CRLF & _
"+button(class="red")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")