# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\w*|\(.*\))(\(class=(\".*\")\))"
test_str = ("+image(class=\"sumup-illustration, vector\" src=\"/sumup-x-debitoor-guide/final_illustration_sumup_en.svg\" alt=\"Meet a better way to stay on top of your SumUp payments\") \n"
"+image(class=\"classTest1, classTest2, classTest3, classTest4\") \n"
"+grid__item(\"md-4\", \"md-vertical-4x-gutter\", \"xs-first\", \"md-last\")(class=\"accent, button, link\") \n"
"+button(class=\"red\")")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.