import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bhttp:\\/\\/[a-zA-Z0-9]{1,}\\.com\\/(([a-zA-Z0-9]{1,}\\/){1,})?(([a-zA-Z0-9]{1,}\\.png)|([a-zA-Z0-9]{1,}\\.jpg)|([a-zA-Z0-9]{1,}\\.gif))\\b$";
final String string = "http://site.com/folder/1/2/asd/sdasd/1.png\n"
+ "file.png\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}