package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Lead status\s*(\w.*)\R([^,]+),\s*([^,]*[^\s,])\s*.*(\d{5})$`)
var str = `Lead status
53 W 70th St
New York, New York 10023`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}