import Foundation
let pattern = #"[httpsHTTPS]+\:\/\/domen\.(com|ru)\/\d\/audio\/\d{5,7}\/[a-zA-Z0-9_.-]+\.mp3"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://domen.com/2/audio/39761/mobile/otnimajj-ili-otnimut-u-tebja-tom-1-chast-1-1.mp3
https://domen.com/2/audio/39761/008-otnimajj-ili-otnimut-u-tebja-glava-8.mp3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)