import Foundation
let pattern = ##"^(\/)(?:[-\w!#$]+)(.*?)$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/questions-math/ask/1
/questions/ask/1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1examples$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)