import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Results_l?(.*)[-_]w(\\d{2})[-_]x(\\d{2})-?y(\\d{2})";
final String string = "Results_lT026020-w01-x01-y02\n"
+ "Results_lGOLDEN-w01-x01-y02\n"
+ "Results_lT9606901A-w01-x01-y02\n"
+ "Results_lT014911R-w25-x01-y02\n"
+ "Results_T503023_w01_x01y06\n"
+ "Results_GOLDEN_w01_x01y06\n"
+ "Results_T503023R_w01_x01y06\n"
+ "Results_T503023R1_w01_x01y06\n"
+ "Results_lT972230R1-w02-x01-y02";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}