re = /Results_l?(.*)[-_]w(\d{2})[-_]x(\d{2})-?y(\d{2})/m
str = 'Results_lT026020-w01-x01-y02
Results_lGOLDEN-w01-x01-y02
Results_lT9606901A-w01-x01-y02
Results_lT014911R-w25-x01-y02
Results_T503023_w01_x01y06
Results_GOLDEN_w01_x01y06
Results_T503023R_w01_x01y06
Results_T503023R1_w01_x01y06
Results_lT972230R1-w02-x01-y02'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end