use strict;
my $str = '/abc/wp-config.php
/123/wp-config.php';
my $regex = qr`^/[a-zA-Z0-9]+/wp-`mp;
my $subst = '/wp-';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";