# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s*(\+[0-9][0-9]\s*|0|)(7.*)/$2/mgix;t' <<< "+41 79 123 456 78
+417612345678
076 123 456 78
07812345678
7712345678
+41 47 123 456 78
+413212345678
021 123 456 78
02212345678
3412345678"