# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\[+[A-Z\d-]+:\s*(.*?)\s*]+$//gm;t' <<< "[ABC1: text1]
[[DC: this is a text]]
[ABC-O: potatoes]
[[C-DF: hello]]"