// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\[+[A-Z\d-]+:\s*(.*?)\s*]+$").unwrap();
let string = "[ABC1: text1]
[[DC: this is a text]]
[ABC-O: potatoes]
[[C-DF: hello]]";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}