#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)\d{2}\/\d{2}\/\d{2}(?:(?!\d{2}\/\d{2}\/\d{2}).)*string.*?\d{2}\/\d{2}\/\d{2}"
Local $sString = "01/20/20" & @CRLF & _
"" & @CRLF & _
"string" & @CRLF & _
"" & @CRLF & _
"01/21/20" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"01/20/20" & @CRLF & _
"" & @CRLF & _
"this isn't the phrase you're looking for" & @CRLF & _
"" & @CRLF & _
"01/21/20" & @CRLF & _
"" & @CRLF & _
"string"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")