import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{2}\\/\\d{2}\\/\\d{2}(?:(?!\\d{2}\\/\\d{2}\\/\\d{2}).)*string.*?\\d{2}\\/\\d{2}\\/\\d{2}";
final String string = "01/20/20\n\n"
+ "string\n\n"
+ "01/21/20\n\n\n"
+ "01/20/20\n\n"
+ "this isn't the phrase you're looking for\n\n"
+ "01/21/20\n\n"
+ "string";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}